Author Topic: Issue with sending emails using own SMTP server  (Read 262 times)

Patrique

  • Newbie
  • *
  • Posts: 41
    • View Profile
Issue with sending emails using own SMTP server
« on: October 15, 2020, 11:41:29 am »
Bonjour,

We'd like to use the SMTP server of our customer for sending emails. This means that the customer is also obliged to take care that his provider is not listed on any blacklist and therefore his end customers do not receive their confirmation emails.

We configured the followeing settings:
SmtpServerAddress   smtp.office365.com
SmtpServerPassword   *******
SmtpServerPort   587
SmtpServerUser   *******

We receive the following error which shows that the encryption wasn't started correctly. We'd suggest not to use STARTTLS but SSL/TLS because connection establishment using STARTTLS is not encrypted and it's recommended to use SSL/TLS instead.

Quote
Sending email
Error in processing. The server response was: 5.7.3 STARTTLS is required to send mail [xxxxxxxxxxx.prod.exchangelabs.com]

I've set up a testMail app in a sandbox workspace for quick and easy testing without using the productive environment of the customer.

Thanks for fixing this issue shortly.

Patrique
« Last Edit: October 16, 2020, 11:17:09 am by Patrique »

volker.thebrath

  • Administrator
  • Newbie
  • *****
  • Posts: 28
    • View Profile
Re: Issue with sending emails using own SMTP server
« Reply #1 on: October 15, 2020, 12:01:44 pm »
Hi Patrique,


I will check that and will come back to you, once it is fixed.

volker.thebrath

  • Administrator
  • Newbie
  • *****
  • Posts: 28
    • View Profile
Re: Issue with sending emails using own SMTP server
« Reply #2 on: October 15, 2020, 12:45:39 pm »
Hi Patrique,


- I added a new workspace setting "SmtpServerSsl". Please set this to true.
- Office365 requires the account user to be the same as the from address.





Patrique

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: Issue with sending emails using own SMTP server
« Reply #3 on: October 16, 2020, 09:42:28 am »
Thanks Volker! Works fine!